Reply
Highlighted
Member
Posts: 9
Registered: ‎15-01-2017
0
Accepted Solution

Linux (recent) connection to smtp.office365.com now fails

I'm sorry to reopen this issue.

I am getting the error with smtp.office365.com now. (smpt.mail.outlook.com previously)

I have a feeling that passwords and security are involved. The one time it worked was immediately after changing my settings (and entering my password).

I have deleted my password in preferences but I cannot connect now so I am not even asked for a password...

"Sending of the message failed.
An error occurred while sending mail: Outgoing server (SMTP) smtp.office365.com is unknown. The server may be incorrectly configured. Please verify that your Outgoing server (SMTP) settings are correct and try again."

 

The problem is not solved.

Member
Posts: 9
Registered: ‎15-01-2017
0

Re: Linux (recent) connection to smtp.office365.com now fails

Oops.... correction, should be (smpt.outlook.com previously) in the last post. my head is beginning to spin.

Member
Posts: 9
Registered: ‎15-01-2017
0

Re: Linux (recent) connection to smtp.office365.com now fails

I'm still chipping away at this problem. I managed to send one message today via smtp.office365.com before the error kicked in. Could it be anything to do with proxy settings in Thunderbird?  

Member
Posts: 9
Registered: ‎15-01-2017
0

Re: Linux (recent) connection to smtp.office365.com now fails

I fiddled around, set things back to normal and with no proxy im TB.

 

After rebooting I managed to connect and send three emails.

 

Closed TB. The re-opened it.

 

I haven't been able to send anything since!

Member
Posts: 9
Registered: ‎15-01-2017
0

Re: Linux (recent) connection to smtp.office365.com now fails

At last I believe I have found the answer, its here...

https://ubuntuforums.org/showthread.php?t=2270096

For my TB 45.5.1 the setting is at...

Edit>Preferences>Advanced>General>Config Editor

Click 'I'll be careful'

Type ipv6 into the search box.

Double click the entry that is found, setting it to true.

Now, as a result, network.dns.disableIPv6 is disabled.

It will appear bold because it is now user set.

I will not mark the issue as solved until I have let things run for a few days but I am pretty confident!