Showing results for 
Search instead for 
Did you mean: 

Wire Lan Port 4 down - BT Hub 5



I have a problem which appears to be intermittent.  I have a NAS connected directly to the router HUB 5, each port on the router is connected to a device:

port 4 NAS1 ( - static)
port 3 NAS2 ( - static)
port 2 PC window 10 ( - static)
port 1 powerline adapter
(IP addresses defined using DHCP by the router)


Every now again the following is logged by the HUB 5 

10:46:15, 03 Oct.    (148429.150000) Wire Lan Port 4 up
10:46:12, 03 Oct.    (148425.740000) Wire Lan Port 4 down
10:46:09, 03 Oct.    (148422.740000) Wire Lan Port 4 up
10:45:59, 03 Oct.    (148413.370000) Wire Lan Port 4 down
10:45:50, 03 Oct.    (148404.370000) Wire Lan Port 4 up
10:45:47, 03 Oct.    (148401.370000) Wire Lan Port 4 down
10:45:41, 03 Oct.    (148395.370000) Wire Lan Port 4 up
10:45:38, 03 Oct.    (148392.330000) Wire Lan Port 4 down
08:55:47, 03 Oct.    (141801.060000) Wire Lan Port 4 up
08:55:35, 03 Oct.    (141788.980000) Wire Lan Port 4 down
08:55:14, 03 Oct.    (141767.910000) Wire Lan Port 4 up
08:55:11, 03 Oct.    (141764.910000) Wire Lan Port 4 down
08:55:08, 03 Oct.    (141761.910000) Wire Lan Port 4 up
08:55:02, 03 Oct.    (141755.910000) Wire Lan Port 4 down


as can be seem this occurs every few hours, and sometimes the connection is so bad I have to disconnect the NAS or just stop using it.


I've changed the network cables.
I've swapped the network cables between the two NAS.
I've rebooted the NAS many times.
I've changed the Port connection on the router, i.e. used port 1 for the NAS1.
I've disconnected the powerline adapter thinking perhaps that was causing problem(network connection problems still occurred).
I've rebooted the router many times,
and still the same intermmittent network problem occurs.


So is the port on the router faulty?

Is there some type of diagnostic check I can perform to check the system?

Any advice would be helpfull.




Power User

Since the problem seems related to the port NAS1 is connected to, it looks like the problem is with NAS1.


Have you tried connecting NAS1 to your BT Hub 5 via an intermediate switch - that is,connecting NAS1 to a port on a separate switch and then connecting that switch to your Hub5 port? (I have known servers refusing to connect to a switch reliably when the port link auto-negotiation fails yet inserting a different switch between the two resolves this).


What operating system does NAS1 run?




Andy, Thanks fro your reply.

I do agree it does seem like NAS1 contains the problem.  What I did yesterday was to replace the network cable(again) from the router to NAS1, and now the issue has gone away, no packet loses today.  But I'll keep monitoring the situation.


The strange thing is that I've replaced the cable before and that solved the issue for a couple of weeks, until the connection problem re-occurred.


It could be two faulty cables, but that does seem odd!


I haven't got an intermediate switch to try your suggest, but I'll bear that in mind.


I'll post back in a week or two, even if the problem is solved.


My Nas is Synology running a flavour of Linux


Looking at the Hub logs Port 4 keeping going down, but no package lose!


17:10:24, 04 Oct.(257875.310000) Wire Lan Port 4 up
17:10:21, 04 Oct.(257872.310000) Wire Lan Port 4 down
16:50:28, 04 Oct.(256679.390000) Wire Lan Port 4 up
16:50:19, 04 Oct.(256670.310000) Wire Lan Port 4 down
16:50:10, 04 Oct.(256661.190000) Wire Lan Port 4 up
16:50:07, 04 Oct.(256658.140000) Wire Lan Port 4 down
11:34:44, 04 Oct.(237736.150000) Wire Lan Port 4 up
11:34:40, 04 Oct.(237732.830000) Wire Lan Port 4 down




Andy, Just to update this post. Since the 4th Oct, after replacing the network cable(again) and making sure it was not wound up in a loop, I've had no problems with Port 4 going down.


I also noticed that the network cable to Port 3 of the router was installed parallel to a power cable runing to the 4 gang socket which powers the router.  So I moved this as it occurred to me that would cause an issue too!


Hopefully the problem is solved!