cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to connect to network file server over VPN using SMB protocol

cupidstunt1992
Member

Hello all,

Would love any help possible with resolving a problem that my entire business seem to be facing.

Internally we have multiple file servers and due to now remote working need to be able to access these over VPN. For some reason only my users who are with BT have issues with connecting, I myself have actually just moved from Virgin to BT, on Virgin I was able to access the file server without any problems but now I'm unable to.

Any help with this would be very helpful, as a side note, I have already ensured that the web protect is disabled and all other protections are disabled.

Again any help is appreciated.

Thanks 

K

2 REPLIES 2

kelper
Grand Master

You will get more help and quicker if you search Google.  SMB is out of date and deprecated for security issues unless you use Windows 10 or later.   I'm no expert, but I think you need someone to attend and configure your network safely.  Have you contacted your local Chamber of Commerce for advice?  Are you paying BT for 24/7 tech support?

Your VPN provider might also offer advice.

rachelgomez123
Member

Ways to fix-

1. Fix untrusted connection
If your network doesn’t trust your computer, it will prevent it from accessing any shared resources. Your PC might still be able to connect to the network (thanks to the VPN server and valid authentication data), but you won’t be able to discover devices or see shared folders.

In order to fix the untrusted connection, make sure that your date and time match the ones on the domain. For instance, if you’re connecting from another country, you can match the domain’s timezone to ensure that your PC won’t be seen as an intruder.

Just disconnect from the domain, adjust your date and time accordingly, and try reconnecting. Also, try to find out if another computer has the same IP assigned as your machine, as this could lead to conflict between addresses.

2. Make sure your DNS is configured correctly
Usually, when you connect to a VPN, you shouldn’t need to configure any additional parameters. Ideally, you should only locate the VPN connection, hit the Connect button, and maybe type some credentials, but that’s the end of it.

Check if your DNS configuration doesn’t conflict with the server’s addresses. More so, reach out to the VPN’s administrator and ask them for guidance on how to configure your DNS properly, if possible.

3. Check your firewall settings
Windows 10’s firewall is a ruthless, yet effective tool. It can block a lot of data from ever reaching or getting out of your machine. Sometimes, it gets a bit overzealous and blocks even harmless, yet useful data.

For that reason, it would be a good idea to make sure that your firewall doesn’t block any incoming VPN connections. Sure, if that were to happen, you might not even be able to access the VPN server, in the first place, but it doesn’t hurt to try.

4. Uncheck the default gateway setting
When you configure the VPN connection, there’s a Use default gateway on remote network option that needs to be disabled. You can find it in the VPN’s TCP/IPv4 properties window, in the IP Settings tab.

Just make sure it’s not selected since this feature is often used when you need to configure split tunneling on Windows 10’s VPN.

Split tunneling is a useful feature that lets you split your traffic by routing a part of it through the secure VPN tunnel and the other part through your default connection.

5. Turn off password-protected sharing
Hit the Win key on your keyboard
Access the Settings app
Head over to the Network & Internet sectionChoose Network & Internet
Select the Status section
Locate the Network and Sharing Center button in the Status section and click itNetwork and sharing center
Click the Change advanced sharing settings buttonChange advanced sharing settings button
Locate the All Networks section and expand itExpand the All Networks section
Turn the password-protected sharing feature off, turn it on againToggle password-protected sharing option
Finally, disable it once more
Click the Save changes button
Restart your computer
Connect to the VPN server
Check if the problem still persists
Most of the time, you might not be able to see any shared resources due to the password-protected sharing feature being activated. More so, it’s not uncommon that de-activating it is not properly registered by Windows.

Hence, you might need to switch it off, switch it on again, and then switch it off one more time so it gets deactivated.

 

This may help you,

Rachel Gomez