Showing results for 
Search instead for 
Did you mean: keeps appearing in sent box


Hello. When looking at the sent section of the BT Mail Account when you look at an email that has been sent at the From: appears instead of the actual BT Mail Account Email Address. When you hover over the the actual BT Mail Acccount Email Address does appear. 


As this is Email is predominantly used for Business how can I make sure that the actual BT Mail Account Email Adress appears permanently in the From: of a sent email instead of


With this email we send a lot of business emails to clients and they notify us regularly that this happens. It has happened for some time now and appears on every single email whether on the Internet or on IPhone/IPad.


Help with this problem would be very much appreciated.


Many Thanks 


Grand Guru

Hi there 14HjC,


have you been on contact with the helpdesk to get the email address/mai program checked out to make sure all the settings are correct?




Power User

You can block up to 500 senders. Emails from these senders will be automatically moved to your Spam folder.

  • From the "Settings" tab, select the "Blocked senders" folder and click on the Add button
  • Type in the email address that you want to block and click Save
  • The email address will now show up in your list of blocked senders and you'll see a confirmation message
  • To remove a sender from your blocked sender's list, simply select the email address, click Delete and then Save

Hope You Find This Useful,