Showing results for 
Search instead for 
Did you mean: 




Hope someone can help with this because I'm stumped.  I was connecting to the internet through a Netgear Router and I have two NAS boxes (Drobo 5N and a Synology).  My primary machines are Mac's.  When I switch to using the Home Hub (3) that was supplied I encounter problems with the NAS boxes.   If a Mac goes to sleep, when it wakes I can no longer connect to the NAS Boxes (they just say unavailable when you select them).  Rebooting the machine allows me to connect.


Switching back to the Netgear router and the problem goes away.  Are there any settings / protocalls I need to set in the Home Hub as I cant figure out whats causing this, as the problem only happens when I have the Home Hub plugged in.


Thanks in advance for any advice given.


Grand Guru

Hi dhcrees,


I think you have posted in the wrong forum, if you are having an issue with the BT Home Hub, you need to speak to our home/residential support teams.  Their forum is found here or you can contact their helpdesk directly via here.




I hope this helps







Hi @dhcrees 


There is a known issue with the Hub 3 not getting along well with Macs,


What would be best is if you tried the hostname fix.



  1. Click on the apple symbol and select "System Preferences"
  2. Select "Sharing"
  3. Change the name shown so that there are no spaces in the name and press enter, if there are currently no spaces and you want to use the current name change this, press enter, then change this back and press enter.
  4. Copy the new mac hostname
  5. press "show all" to return to system preferences
  6. select the current adapter (wired, wireless, etc) then click advanced
  7. go to the TCP/IP tab
  8. Paste the hostname in to the "DHCP Client ID:" box
  9. Click OK
  10. Click apply

The connection will hang for about 10 seconds and when it reconnects try putting the mac into Sleep Mode and then wake it up.


Hope this helps