Showing results for 
Search instead for 
Did you mean: 

Connecting from wireless to wired printer connected via BT Business Hub 3


I'm using BT Business Hub3 as the main router/hub.  I have devices connected via wired and wireless connections and these all show correctly under "Business Network" from advanced settings.


Everyting works fine apart from printing...


The printer is connected via a wired connection.  Devices elswhere on the network connected via wired connection can see the printer and print to it (which involves waking it from power-save mode).  


But devices on the wireless connections see the printer as offline and cannot print.  Te only way to resolve is to power-cycle the printer everytime you want to print, at which point, the wireless devices can see it and print.  


Can anyone offer any pointers as to where I should start looking to resolve this?  It appears as though the hub is creating some kind of barrier between the wired and wireless devices somehow but I can't think what configuration option would be controlling this?



Paul Williams


Grand Guru

Hi pwilliams73625,


what sounds like is happening, is when the printer is going in to powersave mode it is loosing its IP/connection to the hub so that the hub is no longer able to see it.


What you could try is manually set an IP within the printer and if the printer has the option set it to wake on LAN.


The best people to speak to would be our IT Support managers (ITSM) on 0800 500 247 as printer setup is not something the normal helpdesk can help with.






Mark, thanks.  I'll try setting a static address.  Can't find wake on LAN setting.  Although it seem to wake fine when addressed by a wire device.


I also notice that when I try and connect to my Sky+ box which is on a wired connection from my iPhone app which is wireless, it doesn't immediately find the device and can take at least a minute and forced scan to locate it.  Which is weired because the Sky box is defintely on.  


I'll play around with static addressing and see if that helps.


Thanks for taking the time to reply.



Hi @pwilliams73625 


Can you do me a favour and enable "Dynamic routing" on the hub?


That's under


Settings > advanced settings > Broadband > routing < Dynamic routing


and let me know what happens?


Hope this helps