cancel
Showing results for 
Search instead for 
Did you mean: 

BT Business Hub 2 connection with Tenda Nova MESH router

Niceone
Member

I just switched from a BT Home Hub (residential line) to a BT Business Hub 2 (business line) to make business accounting easier for my small home business.

I have a 3 device Tenda Nova setup that worked well with the Home Hub but steadfastly refuses to connect with the Business Hub.

The automatic detection in the app fails every time despite using a wired connection to the BT Business Hub and the hub operating normally and being restarted and connected  to the Tenda device.


I'm not using a static IP.

The BT Broadband home PPPoE details are widely available and I (believe) I used these to set up the Tenda mesh network when I installed it ? years ago. The problem I have is the BT Business Broadband has no password as BT indicate this isn't required for business customers. However, the PPPoE setup on the Tenda app requires a password so I'm unable to progress through manual setup.

Any advice would be appreciated that won't conflict with the additional powerline adapters I also use and which have worked seamlessly since switching hubs.

 

Many thanks

4 REPLIES 4

kelper
Grand Master

I had to ask BTB for my username and password - the generic one won't work.  One of the mods will help so check back here quite often.  Meanwhile, you could try username green-light@service.btclick.com and password zer0touch.  This may work if you don't need a static IP

@kelper thanks for your assistance but unfortunately that combination didn't work for me.

 

I'll leave it a day or so to see if anyone else can assist then contact BT and post any info I receive for information.

 

Cheers

 

 

VickyK
Administrator
Administrator

Hi @Niceone,

 

Thanks for reaching out to us.

 

I'm sorry to hear about the issues you're having with connecting the Tenda Nova to your Business Hub. We can't guarantee the compatibility of third party systems with our hub. 

 

Can I check if the Tenda Nova setup is to extend your Wi-Fi signal in your property? 

 

Thanks,

 

VickyK 

@VickyK, that is the intention, including it's own guest wifi.

 

I spoke with tech support today and in a roundabout way it has been fixed.  I'll post and explanation to the solution here.