cancel
Showing results for 
Search instead for 
Did you mean: 

BT Smart Hub IP Address

Sean_L
Member

I have a new BT Business Smart Hub Type A to replace an existing (and faulty) hub.  I cannot set the IP address to match my LAN settings.  
My internal IP address range is 192.9.200.x (it's an odd range which I inherited but is valid)
I have tried to set the Hubs IP address to 192.9.200.31 and set the DHCP range to 192.9.200.200 - 192.9.200.230 but it will not save the settings.   It just says "Changes have not been saved".  
I have this IP address range on my existing BT hub so it should work.  
I have performed a factory reset, connected with a cable and WiFi.  I have turned DHCP on and off, but it just will not accept the IP addresses.  
Any ideas?  
Thanks, Sean

9 REPLIES 9

kelper
Grand Master

Internal IP addresses are normally in one of the following ranges.

10.0.0.0 – 10.255.255.255

172.16.0.0 – 172.31.255.255

192.168.0.0 – 192.168.255.255

When the DHCP process fails, Windows automatically assigns an IP address from the private range, which is 169.254.0.1 to 169.254.254.255

 

192.9.200.31 IP address Information. The IP address 192.9.200.31 was found in United States. It is allocated to COLUMBUS-NETWORKS so you can't use it.

 

But I am no IT guru.

Thanks Kelper. 
However, 192.9.200.x is a valid IP address for a LAN.  It is used on my other BT hub.   I just need my second hub (which is going to be used as a backup) to accept it.    

kelper
Grand Master

What are your other settings?  Gateway and subnet mask for instance.  Maybe the hub is programmed to reject the IP range you have chosen.

In IPv4 settings, try turning off Authoritative DHCP.

 

I tried your settings on my BTB Smart Hub Type A and it said

 

Invalid IP address
Invalid start address range

Invalid end address range

rbjtech
Member

This is correct - you cannot (read 'should not') be able to assign a non RFC1918 (private LAN) address space to your LAN.  This may cause all sorts of routing problems if that LAN needs to connect to the WAN/Public networks, thus most routers assigning 'LAN' interfaces will not allow this.  I'm unsure how the other router was configured this way.

192.9.200.31 is a Public/WAN IP - it should not be used for LAN.

 

Thanks Kelper
I have tried DHCP on and off and also turned off Authoritative DHCP.
I have also used a DHCP range which matches the IP address.  
I think I am onto a loser...not sure how it is working on my Hub 5.  It was a network I inherited so I may have to bite the bullet and change the LAN...yikes!

Thanks.  Not sure how the Hub5 is doing it, but is is connected now...indeed this post is going through it.  
I have bought a second hand Hub5 to see if I can replicate it.  I just need a short term backup solution but will change the LAN in due course.  
Thanks for your help.

How did you 'inherit' this setup?  I bought a Draytek VIGOR 2820n for about £20 on eBay.  It works perfectly but needs specific login details, not the generic BT login.

 

Is there are particular reason why you need to keep this LAN address ?  If all the clients are using DHCP, then it should be easy enough to set both the current and new router to a valid LAN address but if you have fixed local LAN IP's and maybe port forwarding rules etc, then this becomes more complicated.

 

kelper
Grand Master

What faults do you have on your existing hub?  Maybe they are caused by the "illegal" address range?