cancel
Showing results for 
Search instead for 
Did you mean: 

High latency on BT Network

jmiller93
Member

Hello,

 

I've recently noticed that my IPv4 latency is relatively high; IPv6 doesn't seem to be an issue as it's routed differently. I'm connected via ethernet and there aren't any other devices aside from a NAS and some security cameras that don't connect to the wider internet just local.

 

This is also causing issues when loading webpages some requests are timing out, anything on IPv4 is pretty unstable right now.

 

Below is a traceroute and a ping of 8.8.8.8 without any VPN and connected via ethernet.

The latency is quite high I should be seeing latency of 10-16ms

 

Tracing route to dns.google [8.8.8.8]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  BTBUSINESSHUB [192.168.1.254]
  2     9 ms     9 ms     9 ms  host81-134-160-1.in-addr.btopenworld.com [81.134.160.1]
  3    24 ms    20 ms    22 ms  213.120.163.198
  4    10 ms    10 ms     9 ms  213.120.163.248
  5    24 ms    22 ms    22 ms  31.55.187.192
  6    47 ms    46 ms    47 ms  core1-hu0-6-0-6.southbank.ukcore.bt.net [213.121.192.72]
  7    34 ms    34 ms    35 ms  peer3-et0-1-2.slough.ukcore.bt.net [194.72.16.64]
  8    36 ms    39 ms    34 ms  109.159.253.75
  9    32 ms    42 ms    38 ms  216.239.62.75
 10    18 ms    20 ms    18 ms  142.251.52.151
 11    45 ms    45 ms     *     dns.google [8.8.8.8]
 12     *       41 ms     *     dns.google [8.8.8.8]
 13    43 ms    37 ms    41 ms  dns.google [8.8.8.8]

 

Tracing route to dns.google [8.8.8.8]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  BTBUSINESSHUB [192.168.1.254]
  2     9 ms     9 ms     9 ms  host81-134-160-1.in-addr.btopenworld.com [81.134.160.1]
  3    24 ms    20 ms    22 ms  213.120.163.198
  4    10 ms    10 ms     9 ms  213.120.163.248
  5    24 ms    22 ms    22 ms  31.55.187.192
  6    47 ms    46 ms    47 ms  core1-hu0-6-0-6.southbank.ukcore.bt.net [213.121.192.72]
  7    34 ms    34 ms    35 ms  peer3-et0-1-2.slough.ukcore.bt.net [194.72.16.64]
  8    36 ms    39 ms    34 ms  109.159.253.75
  9    32 ms    42 ms    38 ms  216.239.62.75
 10    18 ms    20 ms    18 ms  142.251.52.151
 11    45 ms    45 ms     *     dns.google [8.8.8.8]
 12     *       41 ms     *     dns.google [8.8.8.8]
 13    43 ms    37 ms    41 ms  dns.google [8.8.8.8]

 

I've now done the same to 8.8.8.8 but using their IPv6 address 

 

Tracing route to lhr25s32-in-x03.1e100.net [2a00:1450:4009:81e::2003]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  2a00:23a8:9c0:c400:aa6a:bbff:fef9:ded1
  2    18 ms    17 ms    17 ms  2a00:23a0:112::7
  3     *        *        *     Request timed out.
  4     *        *        *     Request timed out.
  5    13 ms    10 ms    10 ms  2a00:2302::2:100:1f
  6    10 ms    10 ms    10 ms  2a00:2380:3014:8000::3e
  7    10 ms     9 ms    10 ms  peer7-et4-1-2.telehouse.ukcore.bt.net [2a00:2380:14::b9]
  8     *       11 ms     *     2a00:2380:2001:7000::23
  9    10 ms    10 ms    10 ms  2a00:1450:8166::1
 10     *        *       11 ms  2001:4860:0:1::54d4
 11    11 ms    10 ms    11 ms  2001:4860:0:1::54cd
 12    12 ms    10 ms    11 ms  lhr25s32-in-x03.1e100.net [2a00:1450:4009:81e::2003]

Trace complete.

 

Pinging 2a00:1450:4009:81e::2003 with 32 bytes of data:
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms
Reply from 2a00:1450:4009:81e::2003: time=10ms

Ping statistics for 2a00:1450:4009:81e::2003:
    Packets: Sent = 21, Received = 21, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 10ms, Maximum = 10ms, Average = 10ms

 

Speed test below is over IPv6 so the ping is low.

13100787848.png
 

 

 

I've also tested this on a VPN (London) and run a ping and the issue isn't noticeable on this and I get 11-18ms ping to 8.8.8.8.

 

My best guess is something in Southbank/Slough is causing high latency as IPv6 is working fine (Telehouse) I'm wondering if this is an isolated edge case issue to me or if anyone else is experiencing the same issue? 

 

3 REPLIES 3

kelper
Super User

jmiller93
Member

Hey, it was just a speed test my ping was 9ms, Download was 55.63 Mbps and the upload was 15.83 Mbps.

Cazaresazd
Member

Turn off any downloads, and be sure to check for anything that's downloading in the background. Close any unused applications or browser tabs. Check for malware. Use an Ethernet cable to connect your device to your router or modem, if at all possible.

 

mybkexperience