Showing results for 
Search instead for 
Did you mean: 

Smart Hub 3 - some 2.4GHz-only devices don't connect


We have a problem where a handful of 2.4GHz-only Android devices are not connecting to the main WiFi SSID. We have a BT Business Smart Hub 3 with the guest network enabled and all works OK for everything else we've tried connecting. To try and resolve this issue we have tried turning off the 5GHz SSID and simplifying the main WiFi SSID name to 6 lower-case characters and a password of 9 characters (lowercase letters and numbers) but the devices still fail to connect. OK, there main be something wrong with the Android devices, but here is the bit I cannot understand; before and after making these changes, we are able to connect those same devices to the built-in enabled Guest WiFI - the SSID has -Visitor appended to the SSID name and a password of 15 characters including upper and lowercase characters and numbers. And this was with the 5GHz signal still active.



I only have the BTB smart Hub 1, but all my Internet of Things connect easily. Can I suggest you try changing the security type, if only temporarily?   Can you use WPS where you push a button on the router and this allows clients to briefly negotiate with the router?  

What type are these devices?  Laptops, phones, tablets or other such as smart devices like TRVs or lightbulbs?