cancel
Showing results for 
Search instead for 
Did you mean: 

Struggling with Bridge Mode

booshtukka
Member

At my previous address I had Virgin Media, and I just enabled bridge mode and everything worked great. The rest of my network is a series of Eeros/managed switches which I’m very happy with.

When I moved I didn’t have many choices, so I originally got BT residential broadband, FTTC, which is so slow in comparison - but my property sadly has neither Virgin nor FTTP currently available. (If anyone has any ideas on how to get them to run the cables, I’d love to hear them!). The residential BT Smart Hub 2 does not support Bridge Mode, annoyingly.

So I spoke to BT, and they told me if I got business broadband I’d be able to use Bridge Mode. So I upgraded, and they sent a new hub and fitted a new socket with a filter built-in. The new hub looks EXACTLY the same - I assume it just has a different firmware. Seems a bit mean not give the same router features to everyone! Anyway.

When I enable Bridge Mode on the SH2, I get completely inconsistent results. The first time the light went amber, which I believe is what’s supposed to happen. After clicking Save, the admin site never reloads, but this is expected behaviour I think - since that IP is no longer available. But the Gateway Eero never connected to the Internet. So I factory reset the SH2, and tried again, and it failed again, and I gave in for a while. A week later, I tried again and this time it worked! For a while. Until it stopped working a few days later. Then I had to factory reset it again. It works fine in Double NAT mode, but that’s causing issues with various bits of software I need to run for work.

Today I enabled Bridge Mode, and the admin site reloaded (which is weird) and showed Bridge Mode was enabled. But when I run traceroute, I still see Double NAT. And the light remained blue. I turned it off and on again, the light stayed blue. I went into the interface, and turned off and on Bridge Mode. Then it failed to reload (which struck me as a positive thing), but the light stayed blue, and even after rebooting everything I STILL have Double NAT. The Eero is showing its DHCP server as 192.68.1.254 - so I don’t think the Business SH2 is actually in Bridge Mode.

And then today I had to turn power off, when it came back on the light was orange and nothing worked anymore. So I’ve put it back into standard mode, with the Eero in the DMZ. It’s more reliable, but my work VPN doesn’t work anymore - it only worked in the brief moment when Bridge Mode worked correctly.

Is there some magical thing I need to do for Bridge Mode to actually work? Should I be using a Static IP, or connecting the Eeros to the WAN port instead of a LAN port?

Technical support said they never hear from anyone using Bridge Mode, so couldn't help much. They're sending me a new SH2 to try out, but it seems unlikely it will be a hardware issue.

I’m hoping someone here can help!

4 REPLIES 4

kelper
Grand Master

Are you using WAN port #1 on the BTB Smart Hub?

booshtukka
Member

No, I’ve connected my Eero router to LAN 1. Tech support confirmed this is correct. Should it be connected to the WAN port?

kelper
Grand Master

LAN 1 is correct.  The WAN port is labelled broadband on my BTB Smart Hub 1.  I think you need to change some settings on the Gateway router.  I'm looking for the required settings - something to do with PPPoE from memory.

 

It's PPPoA for ADSL and PPPoE for fibre.  Whatever you have now on the Gateway, change it!

kristensmith584
Member

If there's no internet while Xfinity Router is in Bridge Mode, ensure it is configured correctly, and check the cables. Try disabling and re-enabling bridge mode on the first router. Also, try resetting your routers to their factory default settings.    www.homebargains.co.uk