Showing results for 
Search instead for 
Did you mean: 

Upgraded to BT Business FTTP - lost all IPV6 connectivity


Moving from BT FTTP residential to BT FTTP Business should have been a seamless and painless journey.

On my residential service, I had perfect dynamic IPV4 and a fully working IPV6 stack.  For various work related reasons, having a fixed IP address made a lot of sense, so I opted to 'upgrade' from Residential to Business in order to leverage the Fixed IP address in the enhanced 900 service.

Well, you can guess what happened?

BT instantiated the BT Business profile as expected on the planned date.

Tick > fixed IPV4 address - works
FAIL > IPV6 - disabled by BT

I opened a ticket immediately, only to have it closed as resolved 3 times by different team members, with absolutely no update on status, and no working IPV6 stack.

I re-opened a new fault ticket, only to find that I had to spend an hour on the phone with a tier1 helpdesk rep who didn't understand the problem.

Why is BT still provisioning fixed IP services to business customers and totally ignoring the fact that IPV6 is absolutely required in a business context?  Why do the BT frontline helpdesk staff have no idea what IPV6 is?  Why do BT frontline staff have absolutely no idea what to do with the problem, or who to speak to, or what needs to be done to resolve the problem?

I have searched these forums and found lots of instances of the same problem happening, so surely over the last few years BT Business will have become more accustomed to business customers ABSOLUTELY requiring IPV6.  My business lost productivity days as a result of FTTP being implemented without its IPV6 stack enabled for a business user.  Many of our core services are rendered over IPV6 and without it we are dead in the water.

Also, why can I not describe the issue in a fault report?  If logged in to the BT business portal and can see the faults, but I cannot comment on them, I cannot provide the relevant technical logs, and I cannot reopen a ticket that was closed by someone in BT when the matter has actually not been resolved?

IPV6 is here to stay.  The planet has already run out of IPV4 allocations.  It is unfathomable to me that BT would enable BT business fibre and do so by stripping out the IPV6 elements which already work well for residential customers.


Just in case it helps the MOD's on the community in the interim. 

  • I did receive a broadband service ID when the order was completed.  This is an arbitrary number starting 06
  • I received no instructions with respect to updating the default business PPPOE username or password, which remains set at the default of  btbusinesshub @ - if a customised username and password is required why was it not sent to me during onboarding or on completion of the service activation?
  • If I update the broadband username to the old residential settings of bthomehub @  Guess what? I lose the IPV4 fixed IP address in favour of a dynamic one, and I do get a IPV6 Global Unicast Address, a ULA prefix /64 but IPV6 Network Status remains fixed on "Disabled".  But, it shows some hints that the errors on my business broadband are potentially related to the fact that the router is simply using its default btbusinesshub @ identity?  Perhaps part of the process to send me a bt business broadband username and password for the actual PPPOE link has failed to be sent to me?

For now, I'm leaving the Hub set to default credentials because at least that way I do receive my allocated fixed IPV4 address and I'll just have to lose another business day tomorrow with no IPV6 connectivity until the business support team manage to get to the bottom of why my service is not working.


Accepted Solutions


And, we are finally there!  Thanks to the folks on this forum, the BT helpdesk team, the escalations team, BethM and a lot of log-tracing, plus the valiant efforts of some BT techies who replicated the issues, we are NOW GOOD TO GO!

  • We have a static IPv4 address
  • We have a fixed IPv6/56 prefix
  • My LAN works in dual stack and is very happy
  • My WAN works in dual stack and is preferring IPv6 when its available (as its quicker and packets are bigger!)

IPv6 Tests all pass with flying colours....
Screenshot 2024-04-25 104614.png


Testing even completes the most arduous of functions, including large packets....
Screenshot 2024-04-25 104716.png


and, finally, a production public website that runs in both IPv4 and IPv6 natively, and some 3rd party integrations to see if dual stack works correctly in the browser.....

Screenshot 2024-04-25 104801.png

 Again, thanks to the BT team who perceviered with me to get to the bottom of the problem, replicate it, and resolve it.

For those that may be interested, I don't use the BT supplied business hub (1 or 3), using a dedicated 3.4ghz 8 core PC as the router.  We run with a version of pfSense + firewall, router and based on openBSD, although I did use BT supplied Hub in triage, testing and validation of expected and actual results to remove 'variables', for example, a misconfiguration of the router from the equation.  As soon as the config worked on the BT hub we plugged our own, 'more powerful' router and it works identically, just with more muscle and configurability.

pfSense/opnSense (or other 3rd party router) Setup for BT Business Fibre 900


  • LAN - IPv4 Configuration Type = static IPv4
  • LAN - IPv6 Configuration Type = Track Interface (WAN,  IPv6 Prefix ID of 1)
  • WAN - IPv4 Configuration Type = PPPoE (using assigned account username and password from BT)
  • WAN - IPv6 Configuration Type = DHCP6
  • WAN - MTU - Set to 1500
  • Set - Use IPv4 Connectivity as parent interface is TRUE
  • Set - Request only an IPv6 prefix is TRUE
  • DHCPv6 Prefix Delegation size is set to 56
  • LAN DHCP is enabled
  • LAN DHCPv6 is enabled, but set Router Advertisement is set to STATELESS DHCP - as this way, Android phones are happy on the network with IPv6 too

So, that concludes this thread, resolved, with a fully working BT Business Fibre service. 


View solution in original post



For anyone else suffering the same challenge on BT Business Broadband FTTx, I received a call from the business support team this morning indicating that the new BT Business Hub 3 has a bad configuration as it relates to IPV6.  A BT Broadband Business Hub 1 is being posted to me to try out instead.  Given I am now using the assigned broadband username and password on an enterprise grade PPPoE connection and IPV6 is still failing even with an enterprise grade router in place means I have zero confidence that the Hub 1 will make any difference at all.  For now, I continue limping in my business only with IPV4 enabled, but remain disconnected from my core IPV6 infrastructure and upstream servers.

Hi orion_pilot


I want to discuss this case with my contacts in Tech but I would need some account details to pass over to them. Can you please send over a direct message? 



Thanks Beth, appreciated, I have sent you a DM with the details you may need.


My BTB Smart Hub 1 is fine with IPv4 and IPv6.

The BTB HUb will work with the generic user name and password but a third party modem router will not.

I have a Draytek Vigor set up as a backup and I had to enter my unique username and password.

I can tell you the other settings if it would help.

Thanks Kelper, that would be appreciated.  Over the weekend I tried various combinations of residential and business generic broadband usernames, as well as my 'assigned' broadband username and password, all to no avail.  This is definitely something to do with how the FTTP is connected and configured in the exchange.  It was all working perfectly with dynamic IPV4 and DHCP6 based allocations on residential services.

I also use an enterprise router, simply because it gives me better logs and more functionality, and I even put the BT supplied Smart Hub 3 back in its position and saw identical results with all username and password combinations.

But, please, go ahead and send me the config details you have on the Draytek and I'll confirm my settings off them.  But, like I say, this was all working beautifully, albeit dynamically, prior to moving from residential Fibre to business.  I remain very confident this is an issue in the exchange with where the fibre is now getting its configuration.  IPV4 is working perfectly, but IPV6 is completely dead-in-the-water. No response at all from BT side of the equation using standard router configs that I've been using for years.


As a follow up to this topic for anyone else that is suffering similar conditions in future, here is what I have noted in log-trace of the connection requests over PPPoE

If I use standard residential service username, I receive a valid IPV4 address (dynamic) and a /64 PREFIX for IPV6 over DHCP6.  This is expected and works just fine. The only downside is I am paying for a business fixed IP footprint for nothing, but hey ho, at least the service and both IP stacks work.

If I connect using default btbusiness username and standard password of 'BT' then I get my assigned fixed IPv4 address, but no IPV6 functionality.

If I connect using my assigned username and password, I get the correctly assigned IPV4 address (fixed) but no IPV6 functionality.

As I am now on day 5 of no IPV6 I have reset my PPPoE connection to the default BT RESIDENTIAL SERVICE username and password, et voila, at least I can regain access to my IPV6 insfrastructure.

I will be leaving it set up this way until such a time as the BT team manage to figure this out.

The funny thing, in all circumstances is that it is THE SAME access concentrator for all 3 usernames and passwords!  The AC-NAME is always - and the auth protocal is always CHAP with MD5, it is just behaving differently based on the username.  So, something is definitely incomplete in the assigned settings for business users using assigned business usernames and passwords over a PPPoE connection with FTTx service.

I'll leave this one to rest with BT for a while whilst their techies get to the bottom of why business has no IPV6 assignments via the SAME Access Concentrator mechanisms for their PPPoE handshakes.


Hi Folks, another update for you.  The BT team sent out a replacement Business Smart Hub 1 to replace the Smart Hub 3.  As was the expected behaviour, the Smart Hub 1 is fails to obtain its IPV6 configuration from the network and behaves identically to the Smart Hub 3 or my enterprise grade router in this form.  It assigns the fixed IPV4 address, but the IPV6 end of the network remains DISABLED by BT on their network end.  As per....

Screenshot 2024-04-19 120712.png

I tried all permutations of user login name, including my assigned Identity and password, with exactly the same results I get from my enterprise grade router.  - works for IPV4 and IPV6 but with DYNAMIC addresses for IPV4 and IPV6  - works for fixed IPV4 but IPV6 disabled by BT network
*******@hg* - works for fixed IPV4 but IPV6 disabled by BT network  - works for fixed IPV4 but IPV6 disabled by BT network

The access concentrator at is handing off to either of FARLNS03, FARLNS04, FARLNS05 or FARLNS06, and it is HERE on these endpoints that IPV6 is disabled.  If I use residential service identity then the CHAP MD5 authentication and dynamic assignment of dynamic IPV4 and prefix/64 for IPV6 (dynamic) works perfectly, ableit with dynamic addresses.

So, the problem here, is the the FARLNS family of access concentrators, being 3, 4, 5 or 6 are not responding to the IPV6 prefix request, or if they do respond then they are assigning an invalid prefix starting 5e71, or 7270, instead of what we should get, which is a prefix on BT network starting 2a00::

Given the business Hub 3, the business Hub 1 and my enterprise grade router all exhibit the exact same behaviours in all contexts I remain 100% confident the issue here is that the configuration of BT Fibre for Business, in my case, for my exchange is simply not configured correctly.

I am resetting everything back to CONSUMER RESIDENTIAL and will leave the Hubs in the drawer.  They are not the answer to this problem.  The configuration of the BT Access Concentrator is the problem.  The BT Access concentrator named works perfectly for residential customers.  The ones names FARNLNS 3 through 6 are not configurated for Business IPV6 prefix allocations.

I hope that no other business users on BT Fibre face the same challenge, so if this is the case, it should draw our eyes to the setup at the exchange level; not the core level.  @ Beth - would you be so good as to pass this information and context to the Tier2/3 team that are handling this case as I am unable to send them any details as I don't know who they are or what they are doing.

Thanks BT for sending me the SMART hub 1.  It is just a little bit richer in capability that the SMART Hub 3, but it is not the answer to this problem.

Just as a quick follow up, I reset the Business Hub 1 to residential user login, et voila!  IPV6 works instantly....

Screenshot 2024-04-19 122758.png


and I have the exact, and correct IPV6/prefix that I should expect on BT's network.....
Screenshot 2024-04-19 122959.png

This is correct and is in the ASN database as BT-UK-AS BTnet UK Regional Network, so the IPV6 address I receive as a prefix must be in the range from 2a00:2380::/25, which it is....

Screenshot 2024-04-19 123444.png