Showing results for 
Search instead for 
Did you mean: 

Urgent Help Needed...BT Smart Hub 2...Bridging Mode Assistance.


Hello everyone, I hope one of you good people in this community can help me out with my issues. I have tried ringing bt customer service and spent over an hour on the phone  but they haven't been any helpful to say the least.  The person kept going around circles about the everything so here I am.


A bit of background, so I have had a business broadband package with BT for over 5 years now and up till now we had been using a white Openreach dsl modem. I had a broadband cable going from the wall socket (openreach mk4) to the dsl port on openreach dsl modem and then an ethernet cable going from Lan1 on the dsl modem to a Draytek Vigor 2925 router. Everythig had been working fine but I decided to upgrade my package and get their latest deal for broadband + phone + hybrid connect.


Now they sent me a BT Smart Hub 2, an ip phone for their digital phone line and a hybrid connect device. I wanted to use to same third party Draytek router so I put the SH2 into bridge mode and connected the Draytek router to one of the lan ports on the SH2. I tried the WAN port on SH2 but there was no internet on that so I just plugged into on of the four ethernet ports and my Draytek is working...BUT not without issues. I am getting wifi speed of upto 65-70mb on wireless devices BUT on my computer that's connected through an etehrnet cable is only getting around 5-6 mb download and most of the times when i go on to test, it stays on connecting when I hit the go button and never runs thes test. Speedtest app on mobile shows around 60-70 mb as well. So does anyone know what could be the issue here? Why such slow speeds on the wired connection?


Some other questions as well If any of you can answer them for me.


1 - Ever since I turned the SH2 into bridge mode, the round led light on it stays on solid orange. According to the guidebook solid orange led means there is something wrong with the service, but in a normal mode SH2 shows blue led but in bridge mode it turns orange. So is it supposed to turn orange in bridge mode or is there something acutally wrong with it?


2 - My ip phone (Yealink W60B) is supposed to be connected to the SH2. But when I connect to SH2, it doesn't get any connection so I thought maybe because its in bridge mode. So I tried connecting to Draytek where it picked up the network but still wouldnt't pick up the line/ability to call. Whenever I try to ring it says "unknown uri scheme" and when I press the line button on the phone it, it shows empty menu.


3 - The Hybrid Connect 4g device is also supposed to be connected to SH2 but it keeps flashing blue without being able to link to the SH2. Once again I doubt its because the SH2 is in the bridge mode. But is there anyway I can have it set up and connected to SH2 even if the SH2 is in the bridge mode.


4- General question regarding SH2, does it have the ability to bind an ip to a mac address like the Draytek router so even if the whole system gets rebooted, some devices such as cctv get the same ip for remote viewing. I read sometning about the ip reservations but I am not sure if its 100 percent same as binding ip address to mac address.


I wish I could use SH2 but in my experience over the past 5 plus years with BT, their routers just aren't good enough so I have to use the Draytek but its causing so much issues with the digital phone line,hybrid connect and the slow ethernet speeds. At the moment, the only thing I can think of is to use the SH2 in normal mode and just buy a switch to plug everything into it but I am not sure if SH2 is going to able to set up port forwarding and binding ips for remote access to devices such as cctv and epos systems.







Dunno if you got it sorted at all, if so please update your own post with advice, and I appreciate this is a lot later, but I'm having similar issues/questions without the IP phone complexitiy which in our case is running over a VPN to a separate system with a SIP trunk.

I found the 4G hybrid connect needed to be connected for quite some time with the SH2 in normal mode before it all sorted itself out.  Logs showed updating firmware, pairing, checking credentials with BT provisioning system etc. etc  With all this going on I didn't actually need to connect the SH2 to the phone line, we continued to use the exsiting setup.


In the end in this case the BT hub was solid purple and the light on the 4G hybrid connect was solid blue and only when the 4G signal indicator turned white had it finally sorted itself out.  Took about an hour I'd say.


When in this state I turn on bridge mode, the blue light on the 4G connect blinks for a bit (its providing the internet access over 4G alongside the wired internet through our own router in the state I'm describing) but the lights dont change.  So I didn't get orange at all (in bridge mode).




Hi mkashif88,


Ok, let me try and clear things up for you. I will also ask a couple of questions my self. 

Have you got a fibre to the premises broadband (FTTP) or fibre to the cabinet broadband (FTTC) If it is FTTC then you dont need your white open reach modem. The Smart hub should just need connecting staight into the wall socket. DM me some account details and I can have a look for you if you wish. 


Now to answer your questions: 


1: The hub light should go White when in Bridge mode. Something doesnt seem correct. 


2: The Hybrid connect will not work in bridge mode or with any 3rd party router. 


3: You can set the hub up to point to specific Static IP addresses so you can remote into devices. 


If you need any further Support on this, please DM me and I can have a look at your setup and see what I can do to help