Showing results for 
Search instead for 
Did you mean: 

No DNS resolver for computers with Static IP address


This is a technical report on a problem with BT business hub. I have an adequate work-around but others might be interested in the problem.

My Business hub serial +088315+NQ81775780 Firmware version: SG4B1B009313 updated 16 May 2022, has 5 IP addresses allocated ***.**.95.33 to ***.**.95.38 with .38 being used as it's own external address on a BT phone line.

It serves my internal network with DHCP allocating both internal and the external ip addresses.

For my computers with externally routable IP addresses, the hub delivers it's own address ***.**.95.38 as the DNS service provider. It's internal unroutable address is
For my other computers without external IP addresses, the hub delivers as the dns resolver.

For computers with external IP addresses this is always the result:
$ nslookup ***.**.95.38
;; connection timed out; no servers could be reached

But it succeeds when the requester uses the internal IP address:
$ nslookup

Non-authoritative answer:

In fact it totally fails to offer a DNS service on port 53 of ***.**.95.38 thus: (first the internal ip):

$ sudo nmap -p 53 -sU
Starting Nmap 7.80 ( ) at 2022-09-22 13:05 BST
Nmap scan report for
Host is up (0.0023s latency).

53/udp open domain <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<NOTE OPEN<<<<<<<<<<<<
MAC Address: 28:9E:FC:8C:3C:9D (Sagemcom Broadband SAS)

Nmap done: 1 IP address (1 host up) scanned in 0.24 seconds

and the external IP:
$ sudo nmap -p 53 -sU ***.**.95.38
Starting Nmap 7.80 ( ) at 2022-09-22 12:52 BST
Nmap scan report for (***.**.95.38)
Host is up (0.00078s latency).

53/udp closed domain <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<NOTE CLOSED>>>>
MAC Address: 28:9E:FC:8C:3C:9D (Sagemcom Broadband SAS)

Nmap done: 1 IP address (1 host up) scanned in 0.20 seconds

You will note that the port is closed - hence no DNS resolution.

It responds to pings on the external IP from the internal computer:
$ ping ***.**.95.38
PING ***.**.95.38 (***.**.95.38) 56(84) bytes of data.
64 bytes from ***.**.95.38: icmp_seq=1 ttl=64 time=0.907 ms
64 bytes from ***.**.95.38: icmp_seq=2 ttl=64 time=0.843 ms
64 bytes from ***.**.95.38: icmp_seq=3 ttl=64 time=0.879 ms
64 bytes from ***.**.95.38: icmp_seq=4 ttl=64 time=0.926 ms

I am currently using a work-around which is to force an external dns server address ( into each computer I use. After the DNS client times out trying to use ***.**.95.38, it falls back to it's alternative.
Here are the client computer DNS resolvers addresses status:
Link 2 (enp1s0)
Current Scopes: DNS
DefaultRoute setting: yes
LLMNR setting: yes
MulticastDNS setting: no
DNSOverTLS setting: no
DNSSEC setting: no
DNSSEC supported: no
Current DNS Server:
DNS Servers: ***.**.95.38
DNS Domain: ~.

Where you will see the that I forced in. You will note the ***.**.95.38 that was inserted by the hub using dhcp.

BT do not permit me to configure the DNS server address handed out by the hub's dhcp server so I am unable to fix this myself. Nor can I see what processes are running on the hub, though it is clear that DNS resolver is actually functioning because it responds to the internal address even though it is not even listening on it's external address.

To answer the standard questions:
1. Yes I have rebooted the hub
2. Yes I have reset the hub
3. Yes I have tried it with both Windows 10 computer and Linux Ubuntu computer.
4. Yes, I have rebooted each one of those several times.

So, there it is. I don't fancy spending the time on the telephone to BT to report this hub defect.


Power User

Now that you’re convinced it’s likely a DNS error, how can you fix it? Since DNS issues can happen at the computer level, as part of a router problem, or as an error with your internet service provider (ISP), you may have to try a few things to pinpoint the cause and find a solution.

Run your Windows Internet Troubleshooter before you do anything else. This wizard works for a variety of issues and may diagnose and resolve DNS errors without your assistance.
Right-click on the internet icon in your task tray.
Select Troubleshoot problems.
Let the wizard go through all the steps. This may take a few minutes.
If it doesn’t fix your problem, move on to the solutions below, which are designed for Windows 10 users.
1. Rule out ISP issues
Make sure you’re not dealing with ISP issues by trying to connect with another device. If you can bypass the router and connect directly to your ISP, do so. Use these steps:
Look for the WAN or internet port label on the back of your wireless router, and disconnect the cable going into that port.
Take the free end of this same cable and plug it directly into the Ethernet port on your computer.
Turn off the wireless router, so you don’t accidentally connect to it.
Give your computer a minute or two to recognize the new connection. Be sure you are using an Ethernet or LAN connection, and not your WiFi. You may have to restart your computer for the new settings to take effect.
If one of your other devices can connect, it's not an ISP issue at all. If nothing has changed on your end (settings are all the same) and you cannot connect with any of your devices, contact your ISP to see if they are having service issues.
2. Restart your networking equipment
Restart Networking Equipment
ave you tried turning off your router? What about your modem? Restart both of these devices, and then restart your computer to see if this resolves your issues. Be sure to wait for a full 2 to 3 minutes between powering off and powering back on for the best results.
3. Flush DNS cache and reset winsock
Many times, this simple process can get you back up and surfing the web again.
Type “cmd” in the Windows Start Search bar, and select Open Command Prompt.
Type the following exactly as written, and hit enter after each line is typed out
ipconfig /flushdns
ipconfig /registerdns

ipconfig /release
ipconfig /renew
NETSH winsock reset catalog
NETSH int ipv4 reset reset.log
NETSH int ipv6 reset reset.log
4. Perform a clean reboot
Computers get buggy if they run for too long, and a simple restart won’t keep conflicting programs from interfering with one another. Do what’s called a “clean” reboot which will often solve DNS issues because it only allows essential services to run automatically on startup. If DNS problems are caused by software glitches, these steps can help:
Push the Win + R keys at the same time.
In the Run dialog box that comes up, type “msconfig”. Alternately, you can type “msconfig” in the search bar at the bottom of the Windows Start Menu, and select Open for the System Configuration app.
Click on the Services tab within the System Configuration app.
Check Hide all Microsoft services.
Select the Disable all option.
Click the Apply button, then the OK button to save your preferences.
Next, disable applications on startup:
Click on the Startup tab.
Click Open Task Manager.
Start with the first application, and click on the Disable option next to it. Continue doing this for all applications until they are all disabled.
Close the application window.
Restart your computer.
Go back into the System Configuration App.
Click on the Services tab.
One by one, select an application and click to enable it. After you enable each app, see if you can connect to the internet.
If you can reconnect after disabling an application, this is the one causing DNS issues. See the documentation for that app for troubleshooting tips.



Rachel Gomez


A Domain Name System (DNS) is a directory that translates domain names or hostnames into Internet Protocol (IP) addresses. Due to this process, users can easily access websites on the internet through web browsers.


Sometimes, certain DNS error messages can be encountered when accessing a website, one of them being the “DNS server not responding” message. This means that the web browser can’t connect to the site because the DNS server fails to map hostnames to IP addresses correctly.


There are many causes to the “DNS server not responding” error, from misconfigured network adapters to incorrect DNS server addresses. Fortunately, most of these problems lie on the user’s end and can be solved without much effort. Direct2HR Shaws


This Paragraph will go over 11 potential solutions to solve the “DNS server not responding” issue on Windows and Mac and several common causes for this error message.